GStreamer bug affecting Ubuntu 12.04 and other recent Linux distributions

Home Forums Minitube Forums Troubleshooting GStreamer bug affecting Ubuntu 12.04 and other recent Linux distributions

Viewing 40 posts - 1 through 40 (of 40 total)
  • Author
    Posts
  • #12724 Reply
    Flavio
    Keymaster

    Ubuntu 12.04 (Precise), 12.10 (Quantal) and many other recent distro releases shipped with a rather ugly GStreamer bug that breaks MPEG4 playback for many apps, including Minitube and Musictube. https://bugs.launchpad.net/ubuntu/+source/gstreamer0.10/+bug/973014

    Here’s a temporary workaround I found in the bug comments. Let’s hope the bug itself is fixed soon.

    32bit system:

    sudo mv /usr/lib/i386-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so /usr/lib/i386-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so.bak
    

    64bit system:

    sudo mv /usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so /usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so.bak
    

    In alternative, you can use this PPA:

    sudo add-apt-repository ppa:diwic/gstreamer-h264-testing
    sudo apt-get update
    sudo apt-get dist-upgrade
    
    #12760 Reply
    Nicolás Abel Carbone
    Guest

    The workaround worked for me when playing 360p videos, but it is still failing to play 720p or 1080p videos.

    #13045 Reply
    Cristi
    Guest

    the workaround works on kubuntu 12.04 3.2.0-24-generic-pae even with 720p movies. thnx :)

    #13138 Reply
    LoPst
    Guest

    You’re a CRACK!!!!
    Your solution worked perfectly!

    Thank you!!!!!!!!!!!!!!!!!!

    #13381 Reply
    jancsika
    Guest

    Workaround in Debian Wheezy (amd64) is only a partial fix. Some videos which didn’t work before now play, but it is still skipping after playing a few seconds on most videos. (All happened to be mp4s when I tested.)

    Also, when I double click a video on the left column using the touchpad on my laptop, the preview image “sticks” underneath the mouse pointer (and follows it when I move the mouse) until I click again.

    #13398 Reply
    Cri
    Guest

    Just tried the workaround on Debian unstable, but no results.
    Also tried upgrading all gstreamer packages to 0.10.36-1: the audio track now plays, but the video is still stuck at the intro screen; and often audio hangs too after some minutes.

    BTW, I can confirm the “sticky drag image” bug too, very annoying, and never seen before 1.7.1 (or 1.7)

    #13419 Reply
    jancsika
    Guest

    Thanks for confirming, Cri. Flavio– any clue on why this “bad” plugin went from bad to worse in Linux? I remember using Minitube flawlessly awhile back and don’t understand why something would have been changed in Gstreamer to remove support for playing mpeg4s.

    #13420 Reply
    jancsika
    Guest

    I went ahead and filed a bug through the Gstreamer website on Bugzilla. I basically just linked to the discussion at
    http://www.mail-archive.com/desktop-bugs@lists.ubuntu.com/msg602954.html
    and told them there is a patch there to fix the problem. Hopefully somebody will do something about it soon– just type libgstvideoparsersbad.so in google and look at how many different distros have copied this workaround.

    #13426 Reply
    Alejandro
    Guest

    Hello.

    Thank you. That made the trick using Arch Linux.

    As root:
    mv /usr/lib/gstreamer-0.10/libgstvideoparsersbad.so /usr/lib/gstreamer-0.10/libgstvideoparsersbad.so.bak

    Thanks for the great app!

    #13524 Reply
    eddie
    Guest

    The workaround did the trick for both musictube and minitube on ubuntu 12.04. Thanks for two great apps! Hope the bug will soon be fixed.

    #14280 Reply
    Alex
    Guest

    The fix provided by Flavio worked for me under Ubuntu 12.04 32bit. I really hope this nasty bug gets a hotfix or something, even if it’s a LTS. It’s too critical to just leave it the way it is. Anyway, if a bugfix gets release; please let us know, Flavio. Thanks!

    #14895 Reply
    Odie
    Guest

    No Dice…
    libgstvideoparsersbad is not contained in that path (in fact x86_64-linux-gnu contains no data, gstreamer-0.10 is contained in /usr/lib and also does not contain /libgstvideoparsersbad)

    odsus1@odsus1-s5-1014:~$ sudo mv /usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so /usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so.bak
    [sudo] password for odsus1:
    mv: cannot stat `/usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so’: No such file or directory

    Xubuntu 11.10

    #14997 Reply
    hfrankjr
    Guest

    Using Ubuntu 12.04 in Vbox windows 7 on my Dell laptop: VLC, Totem and Youtube work great; Minitube doesn’t. It skips frames. It used to work in earlier ubuntu versions. I’ve tried uninstalling and reinstalling several times, I’ve done “mv /usr/lib/gstreamer-0.10/libgstvideoparsersbad.so /usr/lib/gstreamer-0.10/libgstvideoparsersbad.so.bak,”, but get “mv: cannot stat `/usr/lib/gstreamer-0.10/libgstvideoparsersbad.so’: No such file or directory” Sure enough, there isn’t such a file in /usr/lib/gstreamer-0.10.
    Could there possibly be another solution to try?
    It sounds like Odie and I are having the same difficulty. Any others?

    #15005 Reply
    Flavio
    Keymaster

    Maybe you’re using Ubuntu 64bit?

    #15024 Reply
    hfrankjr
    Guest

    uname -m returns i686 32 bit
    Is there any news about Canonical doing anything about gstreamer?

    #15244 Reply
    Federico
    Guest

    [fed@caos ~]$ cd /usr/lib/gstreamer-0.10/
    [fed@caos gstreamer-0.10]$ sudo mv libgstvideoparsersbad.so libgstvideoparsersbad.so.bak

    Worked a charm. Archlinux 64. gstreamer 0.10.36 @ 30/08/12

    Complimenti per l’applicazione da un concittadino ;)

    #15601 Reply
    titus
    Guest

    this is the line command for openSUSE 12.2, as root: mv /usr/lib64/gstreamer-0.10/libgstvideoparsersbad.so /usr/lib64/gstreamer-0.10/libgstvideoparsersbad.so.bak

    #16426 Reply
    Denise
    Guest

    mv: cannot stat `/usr/lib/i386-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so’: No such file or directory
    linunt mint 13 xfce
    Minitube closes when I click on a previous entry.

    #16427 Reply
    Denise
    Guest

    Linux Mint 13 xfce.
    Apologise for the typo.

    #17816 Reply
    Toby
    Guest

    I am definitely using Ubuntu 12.04 64-bit, and the terminal is telling me;

    mv: cannot stat `/usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so’: No such file or directory

    I’m an absolute beginner at using the terminal, so I have no idea what is going. Any suggestions?

    #17926 Reply
    Flavio
    Keymaster

    Maybe you already moved it. Or maybe you don’t have gstreamer-plugins-bad installed.

    #18167 Reply
    HC
    Guest

    A slightly cleaner fix for Fedora 17:

    sudo chmod 700 /usr/lib64/gstreamer-0.10/libgstvideoparsersbad.so

    #18283 Reply
    mc4man
    Guest

    For Ubuntu fixes for the 0.10 bad plugin used in 12.04 & 12.10 are now available thru a testing ppa
    https://launchpad.net/~diwic/+archive/gstreamer-h264-testing

    #18964 Reply
    Fabio
    Guest

    It works!!!! many thanks!!!!

    #20049 Reply
    johnm
    Guest

    works for openSUSE 12.2 x86_64, thx dood

    #20993 Reply
    Frank
    Guest

    I’ve tried the first solution. Now the video loads well, start, play a few seconds, stop another seconds and then play the rest of the video with no more complications.
    So then I’ve tried the second solution: adding the PPA. And I get the same behavior. May I reverse the first thing I did? I mean, reverse the sudo mk…? In that case, how? I have the 1.9 version and xubuntu 12.04.

    By the way, this is a great app! Thanks for your time and effort!

    #23050 Reply
    Thomas
    Guest

    This is still not working under PowerPc Lubuntu. I did rename /usr/lib/powerpc-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so

    #27165 Reply
    mrojas6996
    Guest

    I have Lubuntu 12.10 and gstreamer 0.10 (nice, good, bad and ugly), and from the bottom of my soul, I say: TTTTTTTHHHHHHHHHHAAAAAAAAAANNNNNNNNKKKKKKKKKKKKKSSSSSSSSSS!!!!!!!!!!!!!!!!!!!!!!

    Really really really THANKS!!!! Flavio you are THE VERY VERY BEST MAN!!

    En serio creeme que te daria un beso de agradecimiento, pero no, porque eso seria raro.

    Regards from the Venezuelan’s land!

    Very Thanks for the solution, Canonical is bad :/

    #28764 Reply
    Lorio
    Guest

    32 bit work around you posted worked.
    sudo mv /usr/lib/i386-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so /usr/lib/i386-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so.bak

    streams play for more than 3 seconds. play completely now. 360p works perfect. and 1080p works perfect too.

    my linux:
    Linux Mint 13.

    Linux a1 3.2.0-34-generic #53-Ubuntu SMP Thu Nov 15 10:49:02 UTC 2012 i686 i686 i386 GNU/Linux

    Cinnamon Desktop

    MiniTube 1.9

    i was running 1.6 and thought the problem with minitube was the version, so i upgraded to 1.9 using this:

    sudo add-apt-repository ppa:ferramroberto/minitube
    sudo apt-get update
    sudo apt-get install minitube

    –Steve

    #30440 Reply
    harsszegi
    Guest

    Thank you HACKER!!Works….

    #30441 Reply
    harsszegi
    Guest

    Thank you HACKER!!Works….sudo mv /usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so /usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstvideoparsersbad.so.bak
    on 64 bit linix mint this command solved the error

    #31575 Reply
    Frank Henderson
    Guest

    I finally solved my Minitube problem. I have a spare old laptop here, installed Ubuntu 11.10 on it and now I can watch Minitube without it acting like I was watching a slide show.

    #31652 Reply
    dino
    Guest

    Hi flavio.
    Thankyou for your apps!

    I’m on Chakra linux (arch derivate) and I’m trying with developers to made minitube works, but still problems.
    I tried to rename the libgstvideoparsersbad.so lib without luck.
    We updated gstreamer-bad to latest version, but allways the same error (sometimes it is possible to play one or two videos, then stop immedialty with any other):
    […]
    Found format 18
    http://www.youtube.com/get_video_info?video_id=HvuEFafFhBA&el=embedded&ps=default&eurl=&gl=US&hl=en”
    Playing “/tmp/minitube-1421646289-dino”
    [xcb] Unknown sequence number while processing queue
    [xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
    [xcb] Aborting, sorry about that.
    minitube: xcb_io.c:273: poll_for_event: asserzione “!xcb_xlib_threads_sequence_lost” non riuscita.
    zsh: abort (core dumped) minitube

    Since I get the same error with mp4 files in bangarang (but not in dragonplayers that use also phonon) I ask you if there is some problem with xcb library and multithread…

    Version of my sotware:
    – kernel 3.6.6-1 (tested also with 3.7)
    – minitube 1.9-1
    – bangarang 2.1-1
    – kdemultimedia-dragonplayer 4.9.5-1
    – gstreamer0.10-bad 0.10.23-9
    – gstreamer0.10-bad-plugins 0.10.23-9
    – xf86-video-nouveau 1.0.1-2

    Let me know if you need any other info.
    thanks

    #31838 Reply
    Frank Henderson
    Guest

    Finally I’ve solved my problem playing Minitube and it’ll work for everybody. Get an old computer and install Ubuntu 11.10. Minitube works like a charm.

    #85591 Reply
    Sanjaya Karunasena
    Guest

    phonon-backend-gstreamer causes this issue. Install phonon-backend-vlc and remove phonon-backend-gstreamer.

    #86252 Reply
    Kash
    Guest

    Sanjay, Thank you!

    It works on Fedora 19 (32 bit) now! I have had this problem for a while just searched and found your suggestion made it work. I tried the other suggestions posted above but it didnt work.
    I installed phonon-backend-vlc

    then I removed phonon-backend-gstreamer (must uninstall this after installing phonon-backend-vlc otherwise it doesnt work)

    now its working fine with the videos that i tried (mostly 360 and some 720 and 1080)

    #86283 Reply
    Ayesha
    Guest

    hey how exactly do i install Install phonon-backend-vlc and delete the other thing?? i have no idea,,

    #88681 Reply
    Fancisco
    Guest

    thank you! so much for this great article a day after puhbsiled :] i accidently downloaded the ati beta graphics driver for ubuntu and found myself with the dreading amd/ati watermark which was a pretty upsetting feeling but this easy script fixed the issue thank you bud oh yeah! dont run in x server run in terminal keep it up ill bookmark this blog and you should take a look at mine also

    #89030 Reply
    Ntokozo
    Guest

    Thanks for this.In my case, however, I also had to roevme the ; (semicolon), in order to make it actually work.As a consequence, I have experienced that the script should be:#!/bin/shLD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so /usr/bin/skype.originstead of:#!/bin/shLD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so; /usr/bin/skype.orig

    #95633 Reply
    Evaeryday
    Guest

    klik

Viewing 40 posts - 1 through 40 (of 40 total)
Reply To: GStreamer bug affecting Ubuntu 12.04 and other recent Linux distributions
Your information: