[Gentoo Linux] Troubless with phonon vs qt-phonon

Home Forums Minitube Forums Troubleshooting [Gentoo Linux] Troubless with phonon vs qt-phonon

This topic contains 0 replies, has 1 voice, and was last updated by  Atlantic777 5 years, 10 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #1950 Reply

    Atlantic777

    Hi! I’ve installed the minitube but when I try to play a video I get this error message:

    [console output]

    Phonon error: “Your GStreamer installation is missing a plug-in.” 2

    I have these gstreamer plugins installed:

    [I] media-libs/gst-plugins-bad (0.10.22@08/22/2011): Less plugins for GStreamer
    [I] media-libs/gst-plugins-base (0.10.35(0.10)@08/22/2011): Basepack of plugins for gstreamer
    [I] media-libs/gst-plugins-good (0.10.30(0.10)@08/22/2011): Basepack of plugins for gstreamer
    [I] media-libs/gst-plugins-ugly (0.10.18(0.10)@08/22/2011): Basepack of plugins for gstreamer
    [I] media-plugins/gst-plugins-a52dec (0.10.18(0.10)@08/22/2011): plugin for gstreamer
    [I] media-plugins/gst-plugins-alsa (0.10.35(0.10)@07/20/2011): plugin for gstreamer
    [I] media-plugins/gst-plugins-dts (0.10.22(0.10)@09/24/2011): GStreamer plugin for MPEG-1/2 video encoding
    [I] media-plugins/gst-plugins-dvdread (0.10.18(0.10)@08/22/2011): plugin for gstreamer
    [I] media-plugins/gst-plugins-faac (0.10.22(0.10)@12/22/2011): plugin for gstreamer
    [I] media-plugins/gst-plugins-faad (0.10.22(0.10)@08/22/2011): plugin for gstreamer
    [I] media-plugins/gst-plugins-flac (0.10.30(0.10)@08/22/2011): GStreamer encoder/decoder/tagger for FLAC
    [I] media-plugins/gst-plugins-gconf (0.10.30(0.10)@08/22/2011): GStreamer plugin for wrapping GConf audio/video settings
    [I] media-plugins/gst-plugins-jpeg (0.10.30(0.10)@11/30/2011): GStreamer encoder/decoder for JPEG format
    [I] media-plugins/gst-plugins-mad (0.10.18(0.10)@08/22/2011): plugin for gstreamer
    [I] media-plugins/gst-plugins-meta (0.10-r6(0.10)@11/01/2011): Meta ebuild to pull in gst plugins for apps
    [I] media-plugins/gst-plugins-mpeg2dec (0.10.18(0.10)@08/22/2011): Libmpeg2 based decoder plug-in for gstreamer
    [I] media-plugins/gst-plugins-ogg (0.10.35(0.10)@07/20/2011): plugin for gstreamer
    [I] media-plugins/gst-plugins-pango (0.10.35(0.10)@09/02/2011): plugin for gstreamer
    [I] media-plugins/gst-plugins-resindvd (0.10.22(0.10)@08/22/2011): plugin for gstreamer
    [I] media-plugins/gst-plugins-soup (0.10.30(0.10)@12/22/2011): GStreamer plugin for HTTP client sources
    [I] media-plugins/gst-plugins-theora (0.10.35(0.10)@09/02/2011): plugin for gstreamer
    [I] media-plugins/gst-plugins-v4l2 (0.10.30(0.10)@08/22/2011): plugin for gstreamer
    [I] media-plugins/gst-plugins-vorbis (0.10.35(0.10)@07/20/2011): plugin for gstreamer
    [I] media-plugins/gst-plugins-x (0.10.35(0.10)@07/20/2011): plugin for gstreamer
    [I] media-plugins/gst-plugins-xvideo (0.10.35(0.10)@07/20/2011): plugin for gstreamer

    I don’t have installed these two. Do I need them or problem is really in gst plugins?

    * media-libs/phonon
    Available versions: 4.4.2 ~4.4.3 4.5.0 ~4.5.1-r1 **9999 {alsa aqua debug (+)gstreamer pulseaudio vlc +xcb (+)xine}
    Homepage: https://projects.kde.org/projects/kdesupport/phonon
    Description: KDE multimedia API

    * media-libs/phonon-gstreamer
    Available versions: 4.5.0 ~4.5.1 **9999 {alsa debug}
    Homepage: https://projects.kde.org/projects/kdesupport/phonon/phonon-gstreamer
    Description: Phonon GStreamer backend

    Btw, I have this phonon:

    [I] x11-libs/qt-phonon
    Available versions: (4) 4.6.2 4.6.3 4.7.2 4.7.4
    {aqua dbus debug +exceptions pch qt3support}
    Installed versions: 4.7.4(4)(11:25:14 PM 11/02/2011)(dbus exceptions qt3support -aqua -debug -pch)
    Homepage: http://qt.nokia.com/ http://qt-project.org/
    Description: The Phonon module for the Qt toolkit

    It’s not so easy at the moment to switch from qt-phonon to phonon and phonon-gstreamer, but if I have to do that, I will do it.

    What to do!? Thanks in advance…

    Atlantic777

Viewing 1 post (of 1 total)
Reply To: [Gentoo Linux] Troubless with phonon vs qt-phonon
Your information: